Elevated Website Errors
Incident Report for Kaleido AI Platform
Resolved
This incident has been resolved.
Posted Jun 12, 2020 - 16:10 CEST
Investigating
We are currently investigating this issue.
Posted Jun 12, 2020 - 15:57 CEST
This incident affected: remove.bg (Website and Android App).