Image processing delays
Incident Report for Kaleido AI Platform
Resolved
This incident has been resolved.
Posted Aug 31, 2020 - 11:31 CEST
Investigating
We are currently investigating this issue.
Posted Aug 31, 2020 - 11:19 CEST
This incident affected: remove.bg (Website and Android App).