Elevated errors on background removal

Incident Report for Kaleido AI Platform

Identified

We've identified the cause as a shortage of GPU processing capacity for background removal. We're bringing additional capacity online from alternative sources. Some requests may still fail or run slowly until that's done.
Posted Sep 07, 2026 - 11:09 CEST

Investigating

We're investigating elevated error rates and slower response times on the background removal API. This is due to reduced GPU processing capacity. Some requests may fail or take longer than usual. We'll update once we have more information.
Posted Sep 07, 2026 - 10:08 CEST
This incident affects: remove.bg (Website and Android App, Image Processing API).